Failing to open your solution

Jan 16, 2009 at 4:16 PM
Hi Chilberto,

I wanted to write a very basic harness myself, just to display datasets returned from my net.tcp based service. I googled my way to here, thinking I could use the MetadataResolver class. I have downloaded your source to see if that's how you resolve a list of methods offered by a wcf service, but when I try to open your solution it fails on about five or six things. I think this maybe to do with some version control  you're running.

This weekend I'd like to write a basic form that gives me a drop down list of functions I can call that return datasets. Then chose one and have the data displayed in a gridview. Can you give me a hint as to the class I need to use to retrieve this list please or maybe help with getting your solution to work for us? This wcf stuff is really good, I've got a net.tcp based server offering a nettcpbinding and a tcp binding for my mex endpoint. I think I can resolve the list using the mex endpoint.

Anyway I'll try your harness when I get home and give you some feedback, thanks for your time :)

Cheers
Coordinator
Jan 19, 2009 at 9:26 PM
Please see the post: DynamicProxyFactory.

If you post the error that you are receiving, I might be able to help resolve the build issues.  Most likely I did something silly when checking in the source. 

Please let me know the bugs and limitations you find.

Cheers,
Jeff
Jan 20, 2009 at 8:56 AM
Jeff,

Thank you very much for that! I think possibly the problems opening it maybe some VS ignorance on my part.

In fact I just tried it again, fresh download, and it worked fine. I have a dev machine with VS 2003 and 2008 on it, and it failed each time complaining it couldn't find certain projects, despite apparently looking in the right path. I had assumed it was a problem with some version control or similar I didn't have installed. I've just done this again on my host (VS2008 only) and it gave me a convert to latest version/remove source control dialog, I ran this and it opened perfectly! Sorry for wasting your time.

I'll have a look through your dynamic proxy system and see how I get on. I have seen Vipul Modi name before but didn't get on very well with figuring it out for myself.

Off topic, but I'm I've only recently stumbled upon your blog and codeplex. What an excellent pair of sites. I'd like to contribute somehow, I have my own personal site but it's all quite noddy stuff at the moment (http://russtaylor.co.uk). I'd like to improve my skills and so maybe when I have finished my basic test harness I can release it, might be useful to someone?

Thank you for your time,

Russ Taylor
q-delta Limited

email: russ.taylor@q-delta.com
phone: (44) 01823 323203
web: www.q-delta.com


chilberto wrote:

From: chilberto

Please see the post: DynamicProxyFactory.

If you post the error that you are receiving, I might be able to help resolve the build issues.  Most likely I did something silly when checking in the source. 

Please let me know the bugs and limitations you find.

Cheers,
Jeff

Read the full discussion online.

To add a post to this discussion, reply to this email (WCFTestHarness@discussions.codeplex.com)

To start a new discussion for this project, email WCFTestHarness@discussions.codeplex.com

You are receiving this email because you subscribed to this discussion on CodePlex. You can unsubscribe on codePlex.com.

Please note: Images and attachments will be removed from emails. Any posts to this discussion will also be available online at codeplex.com